Experimental IRC log happs-2008-09-30

Available formats: content-negotiated html turtle (see SIOC for the vocabulary)

Back to channel and daily index: content-negotiated html turtle

These logs are provided as an experiment in indexing discussions using IRCHub.py, Irc2RDF.hs, and SIOC.

02:23:43<Axman6>chr1s: i just installed it with cabal
02:23:51<Axman6>re old hscolour
11:26:24<chr1s>Axman6: hm, then I don't know. I'd guess that there are incompatibilities between those packages.
14:49:16<Axman6>chr1s: seems it's a known problem: http://groups.google.com/group/fa.haskell/browse_thread/thread/d9bf1c693a832235#
14:58:41<pflynn>hello I am unable to connect to the happs-tutorial, does anyone know when how long it will be down?
21:22:58<pflynn>Has anyone seen the error "No instance for (Data DefaultD BSC.ByteString)" in src/HAppS/Data/Default.hs:114:0
21:23:12<pflynn>I am using GHC 6.8.2 on CentOS
21:25:23<pflynn>It gives me the possible fix of adding an instance declaration for (Data DefaultD BSC.BYteString)
22:04:18<Saizan>pflynn: you need a newer version of syb-with-class
22:04:38<Saizan>are you installing via cabal?
22:16:22<pflynn>I tried both cabal and darcs
22:16:47<pflynn>do I get syb-with-class from the HAppS darcs ?
22:17:03<Saizan>it's on hackage
22:17:38<Saizan>http://hackage.haskell.org/cgi-bin/hackage-scripts/package/syb-with-class
22:18:19<Saizan>however if you've cabal-install and you're on unix, "cabal install HAppS-Server" should install everything needed
22:21:36<pflynn>hmm, I am installing the packages from hackage one by one with cabal, should I start with HAppS-Server or do I need to use cabal differently?
22:24:17<Saizan>well there are two things called Cabal, the library and the executable which comes with the cabal-install package
22:24:31<Saizan>if you've the latter installed it can fetch and install the dependencies for you
22:24:39<Saizan>sort of like apt-get
22:25:03<pflynn>yes I was using the former, I will try the latter
22:30:18<pflynn>I am using GHC 6.8.2 if I want to install the latest version of cabal-install I would need to upgrade my cabal, would you advise against this?
22:30:53<Saizan>no, it's perfectly safe
22:31:25<pflynn>cool, i will do this and then try to install the server, thanks so much for your help.
22:31:28<Saizan>also, in the cabal-install package there's a bootstrap.sh which automates the installation of cabal-install's deps
22:31:46<Saizan>np :)

Back to channel and daily index: content-negotiated html turtle