14:58:09 <AlexMcLellan> Hi, I've got an issue installing the happstack-tutorial...I've downloaded the happstack-tutorial package via darcs, I've come to install it...but I'm getting dependency issues with regards to QuickCheck,
14:58:20 <AlexMcLellan> cabal: cannot configure Crypto-4.2.1. It requires QuickCheck >=2
14:58:20 <AlexMcLellan> For the dependency on QuickCheck >=2 there are these packages: QuickCheck-2.1,
14:58:20 <AlexMcLellan> QuickCheck-2.1.0.1, QuickCheck-2.1.0.2 and QuickCheck-2.1.0.3. However none of
14:58:20 <AlexMcLellan> them are available.
14:58:20 <AlexMcLellan> QuickCheck-2.1 was excluded because happstack-util-0.4.1 requires QuickCheck
14:58:20 <AlexMcLellan> <2
14:58:21 <AlexMcLellan> QuickCheck-2.1 was excluded because MissingH-1.0.3 requires QuickCheck >=1.0
14:58:21 <AlexMcLellan> && <2.0
14:58:22 <AlexMcLellan> QuickCheck-2.1.0.1 was excluded because happstack-util-0.4.1 requires
14:58:22 <AlexMcLellan> QuickCheck <2
14:58:23 <AlexMcLellan> QuickCheck-2.1.0.1 was excluded because MissingH-1.0.3 requires QuickCheck
14:58:23 <AlexMcLellan> >=1.0 && <2.0
14:58:24 <AlexMcLellan> QuickCheck-2.1.0.2 was excluded because happstack-util-0.4.1 requires
14:58:24 <AlexMcLellan> QuickCheck <2
14:58:25 <AlexMcLellan> QuickCheck-2.1.0.2 was excluded because MissingH-1.0.3 requires QuickCheck
14:58:25 <AlexMcLellan> >=1.0 && <2.0
15:00:45 <AlexMcLellan> Is there anyone here who's had this problem and knows how to resolve it?
15:04:26 <AlexMcLellan> (I already have happstack-util, Crypto & MissingH packages installed, and I now have every available version of QuickCheck installed too)
15:08:01 <rdtsc> AlexMcLellan: try to install it manually
15:08:16 <AlexMcLellan> yeah, I was just about to look into that
15:08:28 <AlexMcLellan> thanks
15:08:30 <rdtsc> i.e. cabal configure, cabal build, runhaskell Setup.hs install
15:08:55 <rdtsc> or all this commands via runhaskell Setup.hs
15:15:45 <mightybyte> AlexMcLellan: You also might want to use the latest version from darcs instead of the last hackage release.
15:15:59 <AlexMcLellan> yeah, I took the version from darcs
15:16:52 <AlexMcLellan> It seems that the dependency conflict is in the happstack-helpers package
15:18:13 <mightybyte> I don't use happstack-helpers.
15:20:37 <AlexMcLellan> Ok - So I guess I can just ignore it then?
15:26:20 <rdtsc> I did not find any documentation on happstack-helpers
15:33:15 <AlexMcLellan> okay, I've been able to manually install the tutorial on my computer by installing the package manually and it's now running. Cheers.
19:44:34 <ben> feuermonster: Also ist die Beweislast in der Tat auf deiner Seite, dass WLAN da nicht dazugehöt
19:44:37 <ben> urgh
19:44:40 <ben> sorry, I am bad at irssi