08:38:45 <Alpounet> hi
08:39:33 <Alpounet> how can one work around the quickcheck < 2 dependency issue when installing gitit (thus happstack) ?
09:47:35 <Alpounet> ok worked it out but now happstack-data doesn't build
10:41:30 <an0nym0us> hey
12:55:28 <stepcut> Alpounet: happstack-data doesn't build ?
12:57:27 <fredune> Does happstack-util (0.4.1) really require QuickCheck version less than 2 ?
12:58:22 <stepcut> fredune: yes. And happstack-util in darcs really requires QuickCheck > 2. Though I think it might be compiled conditionally
13:04:26 <fredune> stepcut: thanks. Installation on Arch Linux fails because of this -- haskell-quickcheck is on 2.1.0.3 already. Guess I can try the darcs version.
13:05:04 <stepcut> k
13:06:43 <fredune> Any idea when the darcs version will become a release?
13:07:21 <stepcut> no. Perhaps I should do one soon.. it is stable.
13:08:00 <Alpounet> stepcut, I managed to build it, eventually
13:08:11 <stepcut> Alpounet: ok
13:08:20 <Alpounet> passing the -O0 option, as described on the mailing list
13:08:59 <stepcut> that was going to be my guess :)
14:11:21 <fredune> stepcup: I tried downgrading quickcheck to 1.2 but got lots of deprecation warnings and a package 25% of the size of v2. Not looking good, though not sure it is unusable.
14:12:28 <stepcut> fredune: yeah, QC2 is very different from QC1, and there is an unavoidable period of pain where some libraries are still on QC1 and some are on QC2
14:13:02 <stepcut> that is why we changed it in darcs to not require any version of QC unless you  build with tests enabled. It's technically the wrong thing to do, but it makes things less painful
14:16:51 <fredune> I see. Can I build 0.4.1 without tests enabled and not require QC ?
14:17:38 <stepcut> fredune: you would have to modify happstack-util and comment out the module that uses QC, and remove the dependencies
14:33:24 <fredune> PATCH (trivial): sed -i 's/QuickQuick/QuickCheck/' happstack-util/tests/Happstack/Util/Tests.hs
15:25:30 <McManiaC> shapr: !
15:25:43 <McManiaC> got a sansa clip+ yesterday :> love it
15:26:15 <shapr> Awesome!
15:52:01 <McManiaC> shapr: they raised the price from 52€ to 67€ one day after I ordered it
15:52:01 <McManiaC> :D
15:52:05 <McManiaC> for 8gb
15:52:08 <shapr> hah
15:52:10 <shapr> Good timing!
15:52:20 <McManiaC> yu
15:52:20 <McManiaC> p
17:52:24 <fredune> ouch! happstack-util needs QC1 but datetime needs QC2. Arch pacman can't handle two versions
17:56:34 <aavogt> fredune: then use cabal-install?
17:58:23 <fredune> another one: does happstack-data (0.4.1) really require HaXml v1.13.* ? -- hackage lists eleven HaXml releases since then, 1.20.2 being the latest
18:06:26 <aavogt> no idea, if it compiles with a newer version, then it will most likely work correctly
18:08:24 <fredune> aavogt: yes looks like I need cabal-install. pacman could be persuaded to work by giving old packages a different name.
18:16:03 <fredune> aavogt: the build fails on the version number check -- haven't tried forcing it to attempt compilation yet. Darcs also specifies old version (HaXml >= 1.13 && < 1.14).
18:39:40 <aavogt> isn't happstack-util optional though?
18:46:43 <fredune> don't see how: happstack-util and happstack-data are in build-depends in happstack.cabal.
18:50:23 <fredune> hmm, HaXml underwent an API transition in Nov 2007 and happstack has not yet moved with it. Can any devs comment?
20:22:54 <stepcut> fredune: happstack-util in darcs does not require any version of QC
20:24:29 <stepcut> fredune: cabal gets mad if an app depends on multiple version of HaXml. So if we switch and nobody else does, that causes more problems than it fixes. Not sure how we will know when the optimal time to switch is though
21:00:08 <fredune> stepcut: on QC: yes understood -- rather than going to darcs I checked whether I could in fact get both QC1+2 by renaming the QC1 package (works!)
21:01:26 <stepcut> fredune: ah
21:02:58 <fredune> Why would you end up depending on more than one version of HaXml -- do your dependencies also depend on it?
21:03:50 <stepcut> fredune: perhaps. Or when people right real apps they may depend on libraries that use HaXml
21:04:44 <fredune> stepcut: oh i see.
21:04:51 <stepcut> dependencies suck ;)
21:08:46 <fredune> yes, but actually I don't think as an app developer you should care about this. I mean the only feasible way to work is for your development version to depend on the latest stable versions of all your direct dependencies.
21:10:16 <stepcut> well, if happstack depends on the latest HaXml, and your app uses the latest HaXml, but you want to use a library that uses the old HaXml, then you are stuck..
21:10:30 <stepcut> unless happstack *is* the library that wants to use the old HaXml
21:10:59 <stepcut> so, some is screwed no matter what..
21:11:27 <stepcut> but HaXml 1.13 has been stable for so long, I am not sure how fast people are going to switch ?
21:16:20 <fredune> They seem to call 1.13 and 1.20 stable, and so everything in between (2.5 years) was "development"? Odd.
21:16:41 <stepcut> yes
21:17:08 <stepcut> and the new version has a radically different API
21:17:16 <stepcut> so it is not trivial to migrate to the new version
21:33:57 <fredune> If only they had evolved gradually... now everyone suffers. You are planning to do the jump tho? The only alternative is to fork.
21:35:28 <stepcut> eventually
21:45:34 <fredune> ok cool, thanks