10:32:46 <bonobo> hi 10:32:53 <bonobo> stepcut: how about my ixset patches? 13:44:03 <timcowlishaw> hey guys, am trying to work through happs-tutorial, but am getting this error, when i try and start the tutorial app, either using happs-tutorial or from GhcI: "Exception: ./introductiontomacid.st: hGetContents: invalid argument (Invalid or incomplete multibyte or wide character)" 13:44:27 <timcowlishaw> Any idea where to start to try and get past this? assume it's some sort of character encoding bug. 13:50:35 <bonobo> timcowlishaw: what GHC do you have? which version? 13:50:39 <bonobo> ghc --version 13:51:29 <timcowlishaw> 6.12.1 13:52:11 <timcowlishaw> i was looking at this - http://groups.google.com/group/pandoc-discuss/browse_thread/thread/8bfb53fb1b59bd1b, my $LANG is 'en_GB.utf8', so that doesn't appear to be the problem 13:52:23 <timcowlishaw> (tried pandoc on the offending file too, and got the same error) 13:53:58 <timcowlishaw> am on ubuntu lucid amd64, if that helps 13:55:51 <bonobo> hmm 13:55:56 <bonobo> I can guess only 13:56:07 <bonobo> but it seems hGetContents wants utf-8 13:56:29 <bonobo> and your fileintroductiontomacid.st is in some other encoding 13:56:40 <bonobo> do you maybe know what is special about this file? 13:56:50 <timcowlishaw> aha 13:56:56 <timcowlishaw> yeo was thinking hte same thing 13:57:13 <timcowlishaw> i just ran iconv on the file and it 'fixed' it - in that it now errors on some other file 13:57:20 <timcowlishaw> i may batch do them all and see what happens 13:57:31 <timcowlishaw> thanks for your help! 13:58:11 <bonobo> ...and create a patch for them after you get them right :) 14:01:19 <timcowlishaw> cool yep can do 14:01:50 <timcowlishaw> is it worth submitting the patch back though? if it's an encoding idiosyncracy on my machine it might do more harm than good to share it? 14:05:57 <bonobo> it is encoding issue from ghc 6.12 onwards forever 14:06:21 <bonobo> so it will actually come back whenever ppl try to do somthing with 6.12 6.14 6.16 14:08:50 <timcowlishaw> aah ok 17:59:10 <tromp> hello happy stackers 17:59:38 <tromp> i'm trying to install happstack-tutorial 18:00:27 <tromp> but it fails on 18:00:27 <tromp> happstack-data 18:00:27 <tromp> >=0.3 && <0.5 18:06:57 <tromp> cabal: cannot configure happstack-helpers-0.50. It requires happstack-data 18:06:57 <tromp> >=0.3 && <0.5, happstack-ixset >=0.3 && <0.5, happstack-server >=0.3 && <0.5 18:06:57 <tromp> and happstack-state >=0.3 && <0.5 18:20:10 <dcoutts> tromp: what is the rest of the message? 18:20:37 <dcoutts> (hpaste) 18:21:05 <tromp> let me rephrase the problem 18:21:20 <tromp> i have happstack-util Latest version installed: 0.5.0.1 18:21:43 <tromp> > cabal install happstack-helpers 18:21:44 <lambdabot> Not in scope: `cabal'Not in scope: `install'Not in scope: `happstack'Not in... 18:21:47 <tromp> Resolving dependencies... 18:21:51 <tromp> cabal: cannot configure Crypto-4.2.1. It requires QuickCheck >=2 18:21:51 <tromp> For the dependency on QuickCheck >=2 there are these packages: QuickCheck-2.1, 18:21:51 <tromp> QuickCheck-22.214.171.124, QuickCheck-126.96.36.199 and QuickCheck-188.8.131.52. However none of 18:21:51 <tromp> them are available. 18:21:51 <tromp> QuickCheck-2.1 was excluded because happstack-util-0.4.1 requires QuickCheck 18:21:52 <tromp> <2 18:22:37 <tromp> why is cabal considering version 0.4.1 of happstack-util ??? 18:23:32 <dcoutts> presumably because something else needs an earlier version of happstack-util 18:23:42 <dcoutts> use the -v flag, with --dry-run to see more details 18:23:50 <dcoutts> of what is being selected, and why 18:25:22 <tromp> happstack-util-0.1, 0.2.1, 0.3.1, 0.3.2, 0.5.0, 0.5.0.1, sendfile-0.1, 0.2, 18:25:22 <tromp> 0.3, 0.3.1, 0.4 and 0.5 18:25:22 <tromp> selecting happstack-data-0.4.1 (hackage) and discarding syb-with-class-0.1, 18:25:22 <tromp> 0.2, 0.3, 0.4 and 0.6.1 18:25:22 <tromp> selecting happstack-util-0.4.1 (hackage) and discarding QuickCheck-2.1, 18:25:23 <tromp> 184.108.40.206, 220.127.116.11, 18.104.22.168, SMTPClient-0.1, 0.2, 0.3 and 1.0 18:27:23 <tromp> probably because of happstack-data 18:27:44 <tromp> Latest version installed: 0.5.0 18:28:40 <tromp> happstack-helpers has dependency happstack-data >=0.3 && <0.5 18:29:02 <dcoutts> tromp: can you use hpaste for the whole log output 18:29:54 <tromp> and presumably all happstack-data prior to 0.5 require a happstack-util < 0.5 18:31:06 <tromp> http://hpaste.org/fastcgi/hpaste.fcgi/view?id=25500#a25500 18:32:51 <tromp> to me, the happstack-helpers happstack-helpers is broken... 18:33:16 <tromp> i mean the happstack-helpers dependency 18:34:17 <tromp> it should be compatible with the latest happstack-util 0.5 18:38:05 <dcoutts> tromp: look, it's selecting happstack-server-0.4.1 18:38:17 <dcoutts> and that will obviously require happstack-util-0.4.x 18:38:59 <dcoutts> tromp: because that it the latest version of happstack-server that it knows about 18:39:00 <tromp> ah, yes. helpers also has a dependency happstack-server >=0.3 && <0.5, 18:39:13 <tromp> which seems unnecessarily restrictive 18:40:25 <tromp> but i'm wondering if there'a ANY combination of versions that satisfies all deps... 18:56:39 <burp> :D 18:56:54 <burp> get the source and modify dependencies :> 21:27:41 <stepcut> I thought thomas updated the tutorial to work with the latest happstack :-/ 21:27:50 <stepcut> maybe he did in darcs but didn't upload it ?